elasticsearch 7.10 启动报错(一)
测试 环境一个es发现停了,启动提示异常
future versions of Elasticsearch will require Java 11; your Java version from [/opt/jdk1.8.0_71/jre] does not meet this requirement Exception in thread "main" java.nio.file.FileSystemException: /opt/elasticsearch-7.10.2/config/jvm.options/jvm.options: 不是目录 at sun.nio.fs.UnixException.translateToIOException(UnixException.java:91) at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102) at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107) at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214) at java.nio.file.Files.newByteChannel(Files.java:361) at java.nio.file.Files.newByteChannel(Files.java:407) at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384) at java.nio.file.Files.newInputStream(Files.java:152) at org.elasticsearch.tools.launchers.JvmOptionsParser.readJvmOptionsFiles(JvmOptionsParser.java:167) at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:128) at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:95)
jdk 还是1.8
看这个错误,需要jdk11.
网速不好,不安装了,用es 自带的jdk 替代下。
elasticsearch/bin目录下vim elasticsearch-env:大约40多活位置
vim elasticsearch-env
去掉标红圈的。不用jdk1.8的,ES_HOME指 elasticsearch自带的jdk。
报存重启即可。
