阿里云 window下 nginx 安装https证书的配置。

首先我这里使用的是阿里云免费的https证书。

免费证书可以申请20个,每个的有效期为1年。

我这里使用的是nginx部署,所以下载nginx的 证书压缩包

下载下来之后解压,有两个文件一个是, 一个是xxx.pem ,另一个是xxxx.key.

nginx 配置如下

看阿里云官方的文档配置后不好用上网又找了找东拼西凑,可算成功了。 Nginx1.16.1 阿里云免费证书 1、先到阿里云控制台把证书文件下载下来,然后解压出两个文件,在Nginx安装目录下新建cert文件夹,将文件放入文件夹中。这里都和阿里的文档是一样的。(不会的自行百度) 2、修改Nginx的配置文件,下面是我的路径C:Nginx ginx-1.16.1conf。首先拉倒最下面,解开最下面那段代码的注释,修改成如下配置,注意有两个server{},是最下面的不是上面的:

server { listen 443 ssl; server_name localhost; ssl_certificate cert/3668546_www.kft-pay.com.pem;#修改成你们的文件名称 ssl_certificate_key cert/kft-pay.com.key;#修改成你们的文件名称 ssl_session_cache shared:SSL:1m; ssl_session_timeout 5m; ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:ECDHE:ECDH:AES:HIGH:!NULL:!aNULL:!MD5:!ADH:!RC4; #使用此加密套件。 ssl_protocols TLSv1 TLSv1.1 TLSv1.2; #使用该协议进行配置。 ssl_prefer_server_ciphers on; location / { proxy_pass http://serverlist;#因为要配置多个Tomcat做负载均衡,所以此处写的是upstream的名称 proxy_set_header X-Forwarded-For $remote_addr; proxy_set_header Host $host; } } 下面是我配置的upstream,如果想增加的话,就将要增加进去的Tamcat的访问路径加进去就可以,注意端口号

upstream serverlist{ server localhost:8080; } 1 2 3 这是最上面的server,只是加了proxy_pass http://serverlist;

server { listen 80; server_name localhost;

#charset koi8-r;

#access_log logs/host.access.log main;

location / { root html; index index.html index.htm; proxy_pass http://serverlist; } 配置文件修改完成了,重新启动Nginx的时候遇到了点问题,重启Nginx发现启动不了,开始上网看以为是端口号被占用,可是我并不是这种情况,然后执行命令的时候发现报错如下: CreateFile<> “C:Nginx ginx-1.16.1/logs/nginx.pid” failed 如果你也是这种情况,在cmd中进入到Nginx安装目录下执行:nginx -c conf/nginx.conf 重启Nginx,配置成功。

至此就配置完成了。又不懂的可以留言给我。本人从事物联网智慧消防多年。有丰富的物联网设备对接能力。项目管理能力。 目前在咱们有课程。有需要的朋友可以去学校一下。在博客首页的连接上。

经验分享 程序员 微信小程序 职场和发展