快捷搜索: 王者荣耀 脱发

HDU 1907 John(Nim博弈)

John

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others) Total Submission(s): 4374 Accepted Submission(s): 2493

Problem Description Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

Input The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints: 1 <= T <= 474, 1 <= N <= 47, 1 <= Ai <= 4747

Output Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

Sample Input 2 3 3 5 1 1 1

Sample Output John Brother

Source Southeastern Europe 2007

需要注意特殊情况:假如全是1怎么办,剩下的就是Nim博弈了
#include<iostream>
using namespace std;
int main(){
    int a[5000];
    int T,n;
    cin>>T;
    while(T--){
        cin>>n;
        int sum=0,step=0;
        for(int i=0;i<n;i++){
            cin>>a[i],sum^=a[i];
            if(a[i]==1) ++step;
        }
        if(step==n)
            if(step%2==0)   cout<<"John"<<endl;
            else            cout<<"Brother"<<endl;
        else
            if(sum)         cout<<"John"<<endl;
            else            cout<<"Brother"<<endl; 
    }
}
经验分享 程序员 微信小程序 职场和发展